This document is out of date, click here to get the latest and greatest documentation for blender.

Blender Documentation Volume I - User Guide

Last modified August 07 2005 S68

Claudio Andaur

Manuel Bastioni

Baldassarre Cesarano

Alejandro Conty Estevez

Karsten Dambekalns

Florian Findeiss

Alex Heizer

Tim van Howe

Wouter van Heyst

Joeri Kassenaar

Martin Kleppman

Lyubomir Kovacev

Johnny Matthews

Reevan McKay

Kent Mein

Martin Middleton

Eric Oberlander

Jason Oppel

Willem-Paul van Overbruggen

Ton Roosendaal

Bastian Samela

Stefano Selleri

Kenneth Styrberg

Bart Veldhuizen

Chris Williamson

Carsten Wartmann

Abstract

This is the Blender Documentation project official Guide. Feel free to add or modify your changes and send them clearly marked to the Blender documentation board (bf-docboard@blender.org).


Table of Contents

I. Introduction to Blender
1. Introduction
What is Blender?
Blender's History
About Free Software and the GPL
Getting support - the Blender community
2. Installation
Downloading and installing the binary distribution
Windows
OSX
Linux
FreeBSD
Irix
Solaris
Building Blender from source
Getting the sources
External libraries needed
Tools needed
Building Blender
Technical support
3. Understanding the interface
Blender's Interface Concept
Keyboard and mouse
The window system
Window types
Contexts, Panels and Buttons
Toolbox
Screens
Scenes
Navigating in 3D Space
The viewing direction (rotating)
Translating and Zooming the View
Perspective and Orthographic Projection
Draw mode
Local view
The layer system
The vital functions
Loading files
Saving files
Rendering
User preferences and Themes
Setting the default scene
4. Your first animation in 30 + 30 minutes
Warming up
Building the body
Let's see what Gus looks like
Materials and Textures
Rigging
Skinning
Posing
Gus walks!
II. Modelling, Materials and Lights
5. ObjectMode
Selecting objects
Moving (translating) objects
Rotating objects
Scaling/mirroring objects
Transform Properties Panel
Duplicate
Parenting (Grouping)
Tracking
Other Actions
Boolean operations
6. Basic Mesh Modelling
Basic Objects
EditMode
Structures: Vertices, Edges and Faces
Vertex, Edge and Face Modes
Basic Editing
Mesh Undo
Smoothing
Extrude
The Blade
The Handle
The Hilt
Spin and SpinDup
Spin
SpinDup
Screw
Warp Tool
Object Hooks
Adding hooks
Using hooks
EditMode options
Hooks panel
7. Advanced Mesh Modelling
Catmull-Clark Subdivision Surfaces
Weighted creases for subdivision surfaces
Edge Tools
Edge/Face select
Face Loop Splitting
Knife Tool
Special Edge Tools
Bevelling Tools
Symmetrical Modelling
Proportional Editing Tool
Noise
Decimator Tool
8. Meta Objects
9. Curves and Surfaces
Curves
Béziers
NURBS
Working example
Surfaces
Text
Special Characters
Extrude Along Path
Curve Taper
Curve Deform
Introduction
Interface
Example
Skinning
10. Materials and Textures
Diffusion
Specular Reflection
Materials in practice
Material Colors
The Shaders
Tweaking Materials
Ramp Shaders
Introduction
Interface
Example
Raytracing Reflections (-)
Raytraced Transparencies (-)
Multiple Materials
Special Materials
Halo Materials
Lens Flares
11. Textures
Textures
Textures from the Material Point of View
Textures themselves
ImageTexture
Environment Maps
Displacement Maps
Displacement Maps on Objects
Interface
Displacement Map usage
Example
Solid and Hollow Glass
Solid Glass
Hollow Glass
UV Editor and FaceSelect
Introduction
The UV Editor
Unwrapping tools
Editing UV coordinates
LSCM Unwrap
Texture Paint
Rendering and UV coordinates
Unwrapping Suzanne
Easy as it "seams"
Unwrapping the mesh
Stitching the Map
Again, please ;-)
Finishing it up
What now ?
Texture Plugins
12. Lighting
Introduction
Lamp Types (-)
Sun Light
Hemi Light
Lamp Light
Spot Light
Ray Shadows
Buffer Shadows
Volumetric Light
Tweaking Light
Three point light
Three point light - Outdoor
Area Light
Global Illumination (and Global Shadowing)
13. The World and The Universe
The World Background
Exposure (-)
Mist
Stars
Ambient Occlusion
III. Animation
14. Animation of Undeformed Objects
IPO Block
Key Frames
The IPO Curves
IPO Curves and IPO Keys
Other applications of IPO Curves
The Time Ipo
Path Animation
15. Animation of Deformations
Absolute Vertex Keys
Curve and Surface Keys
Lattice Keys
Relative VertexKeys
Lattice Animation
16. Character Animation
Introduction: Lights, Camera and... ACTION !
General Tools
The Armature Object
Naming Bones
Parenting and IK chain
The Armature Panel
Skinning
Vertex Groups
Weight Painting
Posemode
Action Window
Non Linear Animation
Working with Action Strips
Constraints
Constraint Types
Constraints Evaluation Rules and Precedence
Influence
Rigging a Hand and a Foot
The Hand
The Foot
Rigging Mechanics
Pivot axis
The Armature
Hydraulics
How to setup a walkcycle using NLA
The path to success
Moving hands while walking
IV. Rendering
17. Rendering
Rendering by Parts
Panoramic renderings
Antialiasing
Output formats
Rendering Animations
Motion Blur
Depth of Field
Cartoon Edges
The Unified Renderer
Preparing your work for video
Colour Saturation
18. Radiosity
The Blender Radiosity method
Radiosity Rendering
Radiosity as a Modelling Tool
Phase 1: Collect Meshes
Phase 2: Subdivision limits
Phase 3: Adaptive Subdividing
Phase 4: Editing the solution
Radiosity Juicy example
Setting up
The Sky Dome
The Radiosity solution
Texturing
19. Raytracing
V. Advanced Tools
20. Particles
Introduction
Simple Particles
A first Particle System
Rendering a particle system
Objects as particles
Making fire with particles
A simple explosion
Fireworks
Controlling Particles via a Lattice
Static Particles
Particle Interaction
Introduction
Interface
Example
21. Other Effects
Introduction
Build Effect
Wave Effect
22. Special modelling techniques
Introduction
DupliVerts
DupliVerts as an Arranging Tool
DupliVerts to Model a Single Object
DupliFrames
Modelling using DupliFrames
Arranging objects with DupliFrames
More Animation and Modelling
Modelling with lattices
How does it work?
23. Soft bodies
Introduction
Blender's SoftBody System
The basics
Interface
Example
24. Volumetric Effects
25. Sequence Editor
Learning the Sequence Editor
First Animation: two cubes
First Sequence: delayed wireframes
Second Animation: A delayed solid cube
Third Animation: a tunnel
Second Sequence: Using the tunnel as a backdrop
Fourth Animation: a jumping logo
Fifth Animation: particle bars
Third Sequence: Combining the logo and the particle bars
Sixth Animation: zooming logo
Assembling everything so far
Conclusion
Sound Sequence Editor
Sequence Editor Plugins
VI. Extending Blender
26. Python Scripting
A working Python example
Headers, importing modules and globals.
Drawing the GUI.
Managing Events.
Mesh handling
Conclusions
Python Reference
Python Scripts
27. Blender's Plugins System
Writing a Texture Plugin
Specification:
Generic Texture Plugin:
Our Modifications:
Compiling:
Writing a Sequence Plugin
Specification:
Generic Sequence Plugin:
Our Modifications:
Compiling:
VII. Beyond Blender
28. Yafray as an Integrated External Renderer
Part 1
Interface
Step-1
Step-2
Step-3
Part 2
Let there be light... And there was Yafray everywhere
Part 3
GI and other features
The available Methods of GI
Features for Full method of GI
Other features of Yafray
The Depth of Field
HDRI or High Dynamic Range Illumination
Closing comments
Glossary for the geeks
Glossary for the geeks
29. From Blender to YafRay Using YableX
What is Yable?
Which Yable?
Where to get YableX?
Installing the script
The Interface
Workflow philosophy.
Global Settings
Material Setting
Light Settings
Yable Juicy example
30. YafRay
Introduction
Installation
YafRay for Windows
YafRay for Mac OSX
YafRay on Linux
Scene Description Language Overview
Shaders
Base Shaders
Procedural
Meta Shaders
Renderable Objects
Transform tag
Object tag
The Mesh tag:
Lights
Spot light
Point light
Sun light
Soft light
Area light
Path Light
Hemi Light
Photon light
Background
Normal Image Background
HDRI Background
Constant Background
Sun/Sky Background
Camera
Render
Filters
Anti Noise Filter
Depth of Field Filter
Glossary

List of Figures

3.1. The default Blender scene.
3.2. The Split menu for creating new windows.
3.3. The window type selection menu.
3.4. Contexts and Sub-Contexts
3.5. Button Window Menu.
3.6. Panel with Tabs.
3.7. An operation button
3.8. Toggle buttons
3.9. Number buttons
3.10. Datablock link buttons
3.11. The Toolbox
3.12. Screen and Scene selectors
3.13. A 3D Viewport's view menu.
3.14. Orthographic (left) and perspective (right) projection.
3.15. Demonstration of camera view.
3.16. A 3D Viewport's draw mode button.
3.17. A 3D Viewport's layer buttons.
3.18. File Selection Window - loading.
3.19. File Selection Window - saving.
3.20. Rendering options in the RenderingButtons.
3.21. User preferences window.
4.1. Blender window as soon as you start it.
4.2. Layer control toolbox.
4.3. Layer visibility controls.
4.4. Our cube in EditMode, all vertices selected.
4.5. The Edit Buttons Window button.
4.6. The Edit Buttons window for a Mesh.
4.7. The cube, subdivided once.
4.8. The sequence of Box selecting a group of vertices.
4.9. The pop-up menu of the Delete (XKEY) action.
4.10. Extruding the arm in two steps.
4.11. Half body.
4.12. The Edit Buttons window.
4.13. Setting the reference center to the cursor.
4.14. Flip the copy of the half body to obtain a full body.
4.15. The sequence of adding the head.
4.16. The Edit Buttons window.
4.17. Setting Gus to smooth.
4.18. Slimming Gus using constrained scaling.
4.19. Making both layer 1 and 10 visible.
4.20. The Panel for numerical input of object position/rotation etc.
4.21. Camera position with respect to Gus.
4.22. Set the reference center to Object center.
4.23. Inserting a Lamp.
4.24. The Lamp Buttons window button.
4.25. Spot light settings.
4.26. The Hemi lamp settings
4.27. The Rendering buttons window buttons.
4.28. The Rendering Buttons window
4.29. Your first rendering. Congratulations!
4.30. The Save menu.
4.31. The Material Buttons window Button.
4.32. The Material Menu button.
4.33. The Material Buttons window and a first gingerbread material.
4.34. The Textures menu button in the Material Buttons
4.35. The Texture Buttons window Button.
4.36. The Texture Buttons window with a stucci texture.
4.37. Settings for the Stucci texture in the Material Buttons window.
4.38. Settings for an additional Noise texture in channel 2.
4.39. A very simple material for the ground.
4.40. Layer visibility buttons on toolbar.
4.41. Sequence for creation of the eyes.
4.42. Creating a mouth with Spinning tools.
4.43. The Spin Tools buttons in the Edit Buttons window.
4.44. The complete Gus!
4.45. Some other candy materials.
4.46. Selecting an existing material from the Material Menu.
4.47. The complete Gus still rendering.
4.48. File type selection menu in the Rendering Buttons window.
4.49. Adding the first bone, an elbowless arm.
4.50. Adding the second and third bones, a leg bone chain.
4.51. The complete armature after duplicating and flipping.
4.52. The Edit Buttons window for an armature.
4.53. The pop-up menu which appears when parenting an Object to an Armature.
4.54. Automatic Skinning options.
4.55. The vertex groups buttons in the Edit Buttons window of a mesh.
4.56. The menu with the vertex groups automatically created in the skinning process.
4.57. Gus in EditMode with all the vertices of group Arm.R selected.
4.58. The six vertex groups.
4.59. The toggle button to switch to pose mode in the 3D Window toolbar.
4.60. You are in pose mode now!
4.61. The current frame Num Button in the Buttons window Toolbar.
4.62. Our first pose.
4.63. Storing the pose to the frame.
4.64. Our second pose.
4.65. Copying the pose to the buffer
4.66. Pasting the copy as a new, flipped, pose.
4.67. Setting the Rendering Buttons for an animation.
5.1. The rotation point selection buttons
5.2. The number dialog
5.3. Group Select
5.4. Freeing Children
5.5. Setting track axis.
5.6. Selecting links.
5.7. Options for boolean operations
5.8. Resulting objects for: intersect, union, difference (top to bottom).
6.1. Basic Objects
6.2. Two pyramids, one in EditMode (left) and one in ObjectMode (right).
6.3. Cube with selected vertices in yellow.
6.4. EditMode selection menu.
6.5. EditMode selection buttons. Vertices, Edges and Faces modes from left to right.
6.6. Vertex mode example.
6.7. Edge mode example.
6.8. Face mode example.
6.9. Mixed mode example.
6.10. Chopped-off pyramid
6.11. Edit Context.
6.12. Specials Menu.
6.13. Undo and Redo
6.14. Undo Menu
6.15. Simple un-smoothed test object
6.16. Set Smooth and Set Solid buttons of EditButtons window
6.17. Same object as above, but completely smoothed by 'Set Smooth'
6.18. Object in editmode with some faces selected.
6.19. AutoSmooth button group in the EditButtons window.
6.20. Same test object with AutoSmooth enabled
6.21. Deformed circle, to become the blade cross section.
6.22. Extrude button in EditButtons context.
6.23. Extrude confirmation box.
6.24. The Blade
6.25. Mesh Edit Menu
6.26. The completed blade
6.27. UV sphere for the handle: vertices to be removed
6.28. First extrusion for the handle
6.29. Complete handle
6.30. Complete Hilt
6.31. Finished sword, with textures and materials
6.32. Glass profile
6.33. Spin Buttons
6.34. Glass profile, top view in edit mode, just before spinning.
6.35. Mesh data - Vertex and face numbers.
6.36. Spinned profile
6.37. Seam vertex selection
6.38. Vertex count after removing doubles.
6.39. Merge menu
6.40. Final render of the glasses.
6.41. Hour mark indicated by the arrow
6.42. Spin Dup buttons
6.43. Mesh selected and ready to be SpinDuped
6.44. View selection for Spin Dup.
6.45. Removal of duplicated object
6.46. Final Clock Render.
6.47. How to make a spring: before (left) and after (right) the Screw tool.
6.48. Enlarging screw (right) obtained with the profile on the left.
6.49. Text settings
6.50. Top view of text and sphere
6.51. Warped text
6.52. Final rendering
6.53. Hooks menu
6.54. Hooks extended menu
6.55. Hooks panel
7.1. SubSurf buttons
7.2. SubSurfed Suzanne.
7.3. SubSurf of simple square and triangular faces.
7.4. Side view of subsurfed meshes. With random normals (top) and with coherent normals (bottom)
7.5. Solid view of SubSurfed meshes with inconsistent normals (top) and consistent normals (bottom).
7.6. A "Non-Manifold" mesh
7.7. A Gargoyle base mesh (left) and pertinent level 2 SubSurfed Mesh (right).
7.8. Solid view (left) and final rendering (right) of the Gargoyle.
7.9. Mesh Tools 1 panel
7.10. Edge sharpness around 0.5
7.11. Mesh panel
7.12. Select Mode menu
7.13. All edges selected
7.14. Edge sharpness
7.15. Two edges selected
7.16. Result
7.17. One open (left) and one closed (right) Edgeloop.
7.18. One open (left) and two closed (center and right) Faceloops.
7.19. Splitting a Faceloop.
7.20. Proportional and Smooth face cuts.
7.21. Midpoints knife with polyline (top); Exact Line knife with single segment (middle) and Exact Line freehand knife (bottom).
7.22. Edge Specials menu.
7.23. Selected Edge Rotated CW and CCW.
7.24. Common Edge rotated CW and CCW.
7.25. Bevelling a cube.
7.26. A plane.
7.27. Right half.
7.28. Mirroring the linked duplicate.
7.29. Editing one half.
7.30. A head. Left: EditMode; Center: ObjectMode; Right: Joined.
7.31. A planar dense mesh.
7.32. A planar dense mesh with just one selected vertex.
7.33. Proportional Editing icon
7.34. Falloff Menu.
7.35. Constant - No Falloff.
7.36. Linear Falloff.
7.37. Sharp Falloff.
7.38. Root Falloff.
7.39. Sphere Falloff.
7.40. Smooth Falloff.
7.41. Influence circle.
7.42. A landscape obtained via Proportional Editing
7.43. Final rendered landscape
7.44. Subdivide tool
7.45. Noise button in EditButtons
7.46. Noise application process. From top left to bottom right: Plane with texture, sub-divided plane, "Noise" button hit 2, 4, 6 and 8 times.
7.47. Noise generated landscape
7.48. Decimator buttons.
7.49. Decimator at work.
7.50. Decimated landscape, top: original; middle: lightly decimated; bottom: heavily decimated.
8.1. Two Metaballs
9.1. Types of Handles for Bézier curves
9.2. Setting Bézier resolution.
9.3. Nurbs Control Buttons.
9.4. Setting Nurbs Control polygon and weights.
9.5. The sketched logo
9.6. 3D window settings.
9.7. Logo sketch loaded as background
9.8. Bézier handles
9.9. Adding a Control Point.
9.10. Vector (green) handles.
9.11. Free (black) handles.
9.12. The finished outline.
9.13. Shaded logo.
9.14. Adding a circle.
9.15. Defining the eye.
9.16. Defining the wings.
9.17. Orb placement within the tail.
9.18. Bevel settings
9.19. Final rendering.
9.20. Add surface menu.
9.21. A sphere surface
9.22. Pre-set weights
9.23. Text Examples.
9.24. Text edit buttons
9.25. Profile (left) and path (right).
9.26. Modified profile (left) and path (right).
9.27. 3D Curve button.
9.28. Profile name.
9.29. Specify the Profile on the path.
9.30. Extrusion result.
9.31. Path local plane.
9.32. Extrusion problems due to y-axis constraint.
9.33. Curve and Surface panel
9.34. Taper example 1
9.35. Taper example 2
9.36. Taper example 3
9.37. Make Parent menu.
9.38. Anim settings panel.
9.39. Curve and Surface panel.
9.40. Add a Monkey!
9.41. Add a Curve.
9.42. Edit Curve.
9.43. Monkey on a Curve.
9.44. Monkey deformations.
9.45. A Surface curve for skinning.
9.46. Profile of the ship.
9.47. Multiple profiles along ship's axis.
9.48. Multiple profiles of the correct shapes.
9.49. Joined profiles.
9.50. Skinned surface in edit mode.
9.51. Final hull.
10.1. Rendering engine basic principle.
10.2. Light re-irradiated in the diffusion phenomenon.
10.3. Specular Reflection.
10.4. Add new material.
10.5. Material Buttons.
10.6. Material Preview, plane (left) sphere (middle) and cube (right).
10.7. Material colors buttons.
10.8. Material Shader buttons.
10.9. Material Diffuse shaders.
10.10. Material Specular shaders.
10.11. Shader overview.
10.12. Additional material sliders.
10.13. Regular material (left), material with Alpha < 1 (center) and material with Emit > 0 (right).
10.14. Material special buttons.
10.15. Ramps Panel.
10.16. Ramps Panel Colorband.
10.17. Input popup menu.
10.18. Method popup menu.
10.19. Factor slider.
10.20. Shader settings.
10.21. Ramp Shader settings.
10.22. Specular Ramp Shader color 0.
10.23. Specular Ramp Shader color 1.
10.24. No Ramp Shader.
10.25. Color Ramp.
10.26. Both Color and Specular Ramp.
10.27. Mushroom Mesh
10.28. Mushroom with one material
10.29. Mushroom with cap vertices selected
10.30. Adding a new material to the mesh
10.31. Multiple user material
10.32. Mushroom with two materials.
10.33. Halo buttons
10.34. Halo results
10.35. Dot matrix image texture.
10.36. Dot Matrix display
10.37. Lens Flare settings
10.38. Lens Flare
11.1. Texture Channels
11.2. Texture selection block
11.3. Material Coordinate input
11.4. Texture mapping
11.5. Coordinate transformation
11.6. Texture coordinate Offsets and Scaling factors
11.7. Texture Inputs
11.8. Texture Outputs
11.9. Output settings
11.10. Texture buttons
11.11. Texture Colorband.
11.12. Copying and Pasting Textures
11.13. First Wood ring texture
11.14. Second Wood ring texture
11.15. Clouds texture
11.16. Final result
11.17. Flat Mapping.
11.18. Cube Mapping.
11.19. Tube Mapping.
11.20. Sphere Mapping.
11.21. Environment Map utilization example
11.22. Reflecting plane material.
11.23. Reflecting plane EnvMap settings.
11.24. Sphere on a reflecting surface.
11.25. Reflecting sphere on a reflecting surface.
11.26. Reflecting sphere on a reflecting surface with multiple reflections.
11.27. Additional texture set-up for BumpMapping.
11.28. Reflecting sphere on a reflecting water with multiple reflections.
11.29. The EnvMap as it is stored.
11.30. Difference between NOR and Displacement Maps.
11.31. Map To panel.
11.32. Disp and Nor settings.
11.33. Positive Displacement selected.
11.34. Negative Displacement selected.
11.35. Subsurf levels 0, 1, 2, (top) 3, 4, 5 (middle) and 6 (bottom).
11.36. Envmap settings to fake refraction.
11.37. Material settings
11.38. Reflection Map
11.39. Final touches
11.40. Rendering
11.41. Setting transparency.
11.42. Setting Reflections
11.43. Hollow Glass
11.44. Entering Face Select Mode.
11.45. Face Select Mode.
11.46. UV Calculation Panel.
11.47. UV Editor.
11.48. UV pre-sets.
11.49. UV Transformation Menu.
11.50. "Stitch" and "Limit Stitch".
11.51. vertex colors modulate texture.
11.52. LSCM unwrapping method.
11.53. The "Paint" tool in action.
11.54. Suzanne with marked seams.
11.55. Pinning UVs.
11.56. Accessing occluded UVs.
11.57. LSCM in action.
11.58. Front group mapped "From Window".
11.59. Two islands in the map.
11.60. Stitching.
11.61. Stitching all together.
11.62. Seams revisited.
11.63. New LSCM unwrap...
11.64. Unfolding the ears.
11.65. The unwrapping stages. Notice the pinned vertices.
11.66. Final exported UV layout.
11.67. Gimp is a 2D app that supports transparent layers.
11.68. Using the UV map as reference for texture maps.
11.69. The three texture maps.
11.70. Adjusting the colour texture map.
11.71. Final render. Really ugly textures... I should paint them again...
12.1. Lamp Buttons.
12.2. Lamp General Buttons.
12.3. Sun Light.
12.4. Sun Light example.
12.5. Sun Light example.
12.6. Hemi Light conceptual scheme.
12.7. Hemi Light example.
12.8. Outdoor Light example. Sun Light Energy=1 RGB=(1.,0.95,0.8) Sun direction in a polar reference is (135°,135°). Hemi Light Energy=0.5 RGB=(0.64,0.78,1.) pointing down.
12.9. Lamp Light Buttons.
12.10. Lamp Light example. In Quad examples Quad1=0, Quad2=1.
12.11. Light decays: a) Blender default linear; b) Blender default quadratic with Quad1=0, Quad2=1; c) Blender quadratic with Quad1=Quad2=0.5; d) Blender quadratic with Quad1=Quad2=0. Also shown in the graph the same curves, in the same colours, but with the Sphere button turned on.
12.12. Spot Light Scheme.
12.13. The Lamp Options buttons
12.14. Spot Light Buttons.
12.15. Spot Light Examples for SpotSi=45°
12.16. Spot Light shadow buttons.
12.17. Spot Light shadow examples.
12.18. Spot Light halo button.
12.19. Spot Light setup.
12.20. Halo rendering.
12.21. Halo Intensity Slider.
12.22. Halo Step NumButton.
12.23. Halo with volumetric shadow, Halo Step = 1
12.24. Halo with volumetric shadow, Halo Step = 12
12.25. Light tweaking setup.
12.26. Simple Light Spot set up.
12.27. Single Spot Light set up with appropriate Clipping.
12.28. Spot Light Clipping tweak. Left: ClipSta too high; Centre: Good; Right: ClipEnd too low.
12.29. Back Light set up.
12.30. Key Light only (left) Back Light only (centre) and both (right).
12.31. Fill Light set up.
12.32. Key and Back Light only (left) Fill Light only (centre) and all three (right).
12.33. Floor Diffuse Light set up.
12.34. Four Light set up.
12.35. Sun and Hemi light for outdoor set up.
12.36. Sun and Hemi light for outdoor rendering.
12.37. Outdoor rendering.
12.38. Area light and its shadow.
12.39. Area light and its shadow 2
12.40. Spot light and its shadow
12.41. Grid setup
12.42. Spot light and its dupliverts
12.43. Fake area light with multiple spots.
12.44. Fake area light with multiple soft spots.
12.45. Cornelius under Area Light.
12.46. Global Illumination scene.
12.47. Sky dome.
12.48. Sky dome with duplicated spots.
12.49. Flipping normals.
12.50. Correct sky dome and dupliverted Spot Lights.
12.51. Spot Light setup.
12.52. Spot Light setup.
12.53. Making spots denser in an area.
12.54. Anisotropic skydome render.
13.1. World Buttons
13.2. Background colors
13.3. Texture buttons
13.4. Mist buttons
13.5. Mist test setup
13.6. Rendering without mist (left) and with mist (right).
13.7. World set up.
13.8. Star buttons
13.9. Star rendering.
13.10. Star settings.
13.11. Ambient Occlusion Panel.
13.12. Effect of the different number of samples.
13.13. Ambient Occlusion with Sky Color. Zenith is blue, Horizon is orange, and type is Blend so that sky goes full orange at Nadir.
13.14. Ambient Occlusion bias values.
14.1. Insert Key Menu.
14.2. The IPO window.
14.3. IPO extension options.
14.4. Extended IPOs.
14.5. The IPOKey mode.
14.6. The IPO window.
14.7. Linear time IPO
14.8. The Action Window with Path Buttons.
14.9. Tracking Buttons
14.10. Complex path animation
14.11. Some frames, the camera fluidly tracking the fighter.
14.12. A frame of the final animation.
15.1. Insert Vertex Keys Menu.
15.2. Reference Key and Speed IPO.
15.3. Absolute Keys.
15.4. The female head we want to animate.
15.5. All but the face vertices hidden.
15.6. Left eye closed.
15.7. Smiling.
15.8. Keys in the IPO Window.
15.9. The IPO curve of Key 1.
15.10. Clipboard buttons.
15.11. All IPOs.
15.12. Sequence.
15.13. RVK in Action Window.
15.14. Lattice setup
15.15. Stretching
15.16. Final lattice deformation
15.17. Some frames of the resulting animation.
16.1. Auto key options
16.2. Pinned Action IPOWindow
16.3. Adding an Armature
16.4. EditButtons for an Armature
16.5. Draw options for Armatures
16.6. Vertex Groups
16.7. Weight Paint Button.
16.8. Pose Mode Menu entry.
16.9. Pose Mode Button.
16.10. Action Window
16.11. Action Window with a Constraint
16.12. Action IPO
16.13. NLA Window
16.14. Expanded Action in NLA Window
16.15. Expanded Constraint in NLA Window
16.16. NLA Action Strip Options
16.17. Constraints Panel.
16.18. Copy Location Constraint.
16.19. Copy Rotation Constraint.
16.20. Track To Constraint.
16.21. Lock Track.
16.22. Follow Path.
16.23. IK Solver Constraint.
16.24. Action Constraint.
16.25. Null Constraint.
16.26. The Arm model
16.27. Drawing the armature
16.28. The armature in side view.
16.29. Placing the armature in side view.
16.30. Wrist IK solver.
16.31. Rigging the finger.
16.32. Rigging the finger.
16.33. Adding the finger IK solver.
16.34. Rigging the other fingers.
16.35. Naming overview.
16.36. Parenting the Thumb.
16.37. Parenting the other fingers.
16.38. Setting the IK solver for the wrist. Selecting the bone.
16.39. Setting the IK solver for the wrist. Setting the Constraint.
16.40. Vertex group names.
16.41. ArmHi.R vertex group.
16.42. Assigning vertices to a group.
16.43. Different Poses.
16.44. A (wrong) leg rig.
16.45. Assigning the IK constraint.
16.46. The rig in pose mode.
16.47. Adding a toe and some more IK Animation.
16.48. Moving the leg.
16.49. Rigging with a null bone.
16.50. Rigging with a null bone.
16.51. Adding the toe.
16.52. Full complete leg rig.
16.53. Zoom on the foot rig.
16.54. Testing the setup.
16.55. Four spider-mech legs.
16.56. The Arm model
16.57. The Arm model with pivot axis.
16.58. The Arm model and its armature
16.59. The Arm model in Pose Mode
16.60. Hydraulic piston.
16.61. Hydraulic piston on the arm.
16.62. Hydraulic piston in Pose Mode.
16.63. Hydraulic piston with mutual tracking.
16.64. Track settings.
16.65. Pose Mode for the arm with hydraulics.
16.66. Adding a flexible tube.
16.67. Adding the armature to the tube.
16.68. The Empty for the IK Animation solution.
16.69. IK constraint.
16.70. Full robot arm in Pose Mode.
16.71. Some common poses in a walkcycle.
16.72. Use copy, paste and paste-flip pose buttons to be happy!
16.73. A nice stroll
16.74. Estimating the STRIDE. Refine the grid if needed!
16.75. Having a rest in the walk
16.76. Hey guys!
17.1. Rendering Buttons.
17.2. Image types and dimensions.
17.3. Image pre-set dimensions.
17.4. Rendering by parts buttons.
17.5. Panorama button.
17.6. Panorama test set up.
17.7. Non-panoramic rendering.
17.8. Panoramic rendering.
17.9. Fish-eye rendering.
17.10. Full 360° panorama with 16.0 lenses.
17.11. Full 360° panorama with 38.5 lenses.
17.12. Render Panel.
17.13. Rendering without OSA (left) with OSA=5 (center) and OSA=8 (right).
17.14. Image and animations formats.
17.15. AVI Codec settings.
17.16. Animation rendering buttons.
17.17. Animation location and extensions.
17.18. Motion Blur buttons.
17.19. Frame 1 of moving cube without Motion Blur.
17.20. Frame 2 of moving cube without Motion Blur.
17.21. Frame 1 of moving cube with Motion Blur, 8 samples, Bf=0.5.
17.22. Frame 1 of moving cube with Motion Blur, 8 samples, Bf=1.0.
17.23. Frame 1 of moving cube with Motion Blur, 8 samples, Bf=3.0.
17.24. Depth of Field test scene.
17.25. Setting the Focus Empty.
17.26. NURBS circle tracking the focus Empty.
17.27. Speed IPO for the NURBS circle path.
17.28. Camera tracking the focal Empty.
17.29. Motion Blur settings.
17.30. Motion Blur final rendering.
17.31. A scene with Toon materials.
17.32. Toon edge buttons.
17.33. Toon edge settings.
17.34. Scene re-rendered with toon edge set.
17.35. The Unified Renderer button.
17.36. Unified Renderer additional buttons.
17.37. Unified Renderer postprocess submenu.
17.38. Field Rendering setup.
17.39. Field Rendering result.
18.1. Radiosity example
18.2. Set-up for Radiosity test.
18.3. Radiosity enabled material.
18.4. Radiosity buttons for radiosity rendering.
18.5. Enabling Radiosity in the Rendering Buttons.
18.6. Radiosity rendering for coarse meshes (left) and fine meshes (right).
18.7. Gourad button
18.8. Radiosity Buttons for Subdivision
18.9. Radiosity Buttons
18.10. Radiosity post process.
18.11. Radiosity rendered Cylon Raider.
18.12. Add a plane
18.13. Plane colour
18.14. Sky dome.
18.15. Flipping the normals.
18.16. Sky dome material.
18.17. Setting Dome and plane 'single sided'.
18.18. Selecting all Meshes.
18.19. Preparing the Radiosity solution.
18.20. Radiosity settings.
18.21. Radiosity solution.
18.22. Rendering of the radiosity solution.
18.23. The Raider's mesh.
18.24. Separating the Raider parts to be textured.
18.25. "Metallic" material.
18.26. Four textures, from upper left corner, clockwise: RaiderBM, RaiderDI, Markings, Raider.
18.27. Texture set-ups.
18.28. Complete material preview.
20.1. Animation Buttons Window
20.2. The emitter.
20.3. The Particle Buttons.
20.4. Particles settings.
20.5. Halo settings
20.6. Shooting stars
20.7. Setting Dupliverted Particles.
20.8. Dupliverted particles rendering.
20.9. Campfire setup.
20.10. Fire particles setup.
20.11. Flames Material.
20.12. Flames Texture.
20.13. Fire Material IPO
20.14. Final rendering.
20.15. The explosion
20.16. Material for the explosion cloud.
20.17. Material for the sparks.
20.18. Texture for both.
20.19. Particle system for the cloud
20.20. Particle system for the sparks
20.21. Particle Multiplication buttons
20.22. Firework Material 1
20.23. Adding a second material to the emitter.
20.24. Material 2
20.25. Particle settings
20.26. Lattice settings
20.27. Lattice deformation effects
20.28. Normal particles, left; Vector particles, centre; and DupliVerted objects following the particles, right.
20.29. Static particle settings
20.30. Material settings
20.31. Texture Colorband settings
20.32. Texture settings in the Material buttons
20.33. Final result
20.34. Particle Interaction panel.
20.35. Force field indicator.
20.36. Vortex field indicator.
20.37. Effects panel.
20.38. Example frame 40.
20.39. Example Deflection settings.
20.40. Example end result.
21.1. Build Effect
21.2. Wave Control Panel
21.3. Wave Origin
21.4. Wave front type
21.5. Wave front controls
21.6. Wave front characteristics
21.7. Wave time controls
22.1. A simple scene to play with.
22.2. The parent mesh can be any primitive.
22.3. The man is parented to the circle.
22.4. The Animation Buttons
22.5. In every vertex of the circle a man is placed.
22.6. Changing the size of the circle in Edit Mode.
22.7. A second row of Magritte's men.
22.8. Show object's axis to get what you want.
22.9. Negative Y Axis is aligned to vertex normal (pointing to the circle's center)
22.10. Positive Y axis is aligned to normal
22.11. Positive X axis is aligned to normal
22.12. Positive Z axis is aligned to normal (weird, huh?)
22.13. Strange tentacle and SubSurfed version.
22.14. Local reference of the tentacle.
22.15. DupliVerts not rotated.
22.16. DupliVerts rotated.
22.17. Our model complete.
22.18. Link's outline
22.19. Link's cross section
22.20. Curve's settings: Curve Path and Curve Follow.
22.21. Clearing origin.
22.22. Tracking the right axis.
22.23. DupliFrames!
22.24. Values for DupliFrames. Note "DupEnd: 35" will end link before curve's end.
22.25. Making Dupli's Real.
22.26. Skinning the link.
22.27. Skinned link.
22.28. Using a curve path to model the chain.
22.29. Curve settings.
22.30. Adjusting the DupliFrames.
22.31. Rotating the link.
22.32. Dupliframed chain.
22.33. A Surface Circle.
22.34. Trapezoidal cross-section.
22.35. Trapezoidal cross section, rotated and translated.
22.36. Rotation IPO for the cross section.
22.37. Translation IPO for the cross section.
22.38. Size IPO for the cross section.
22.39. Using a curve path to model the chain.
22.40. Using a curve path to model the chain.
22.41. An ugly fork.
22.42. A 2x2x2 Lattice.
22.43. Use a suitable resolution, but don't exaggerate.
22.44. Deforming the lattice is a pleasure!
22.45. Bending things.
22.46. A nice fork.
22.47. Poor guy...
22.48. Bending things.
22.49. Scale the lattice to fit the bottle.
22.50. Edit Lattice so that the poor guy is comfortable in his bottle.
22.51. Claustrophobic?
22.52. Final Render. Believe me, he deserved it!
23.1. Softbody settings.
23.2. Bake settings.
23.3. Example Weight Setting.
23.4. Example Wind setup.
23.5. Example Wind Strength IPO.
24.1. Columns on a plane.
24.2. A plain rendering.
24.3. A rendering with built-in Blender Mist.
24.4. The plane set-up.
24.5. The Dupliframed plane.
24.6. Reshaping the Dupliframed Plane IPO.
24.7. Reshaping the DupliFramed Plane IPO.
24.8. Basic Material settings.
24.9. Height limiting texture.
24.10. Basic Material settings for cloud texture.
24.11. Cloud texture settings.
24.12. Final rendering.
25.1. Final result.
25.2. Moving the cube out of the camera view.
25.3. A rendering of the solid cube...
25.4. ...and a rendering of the WireFrame cube.
25.5. Set the animation output filename.
25.6. Adding a video strip
25.7. Placing the strip.
25.8. Mixing two video strips
25.9. Sequence Editor preview button.
25.10. Adding a preview window.
25.11. Sequence with 4 WireFrame cube strips added together.
25.12. Sequence IPO button.
25.13. Defining the brightness of a layer with an IPO
25.14. Four WireFrame cubes combined with fading effects.
25.15. Named META strip
25.16. Animation mask.
25.17. Subtracting the mask from the video.
25.18. Mask subtracted.
25.19. Mask multiplied.
25.20. Adding the two effects
25.21. Two time-shifted layers.
25.22. Adding a 20-vertex circle.
25.23. Spinning the circle around the cursor
25.24. Camera inside the tunnel.
25.25. Camera view of the tunnel interior.
25.26. Tunnel rotation IPO without ease-in and ease-out.
25.27. Rotate the camera to get a more dramatic effect
25.28. A groovy tunnel.
25.29. Setting up the backdrop effect.
25.30. Adding randomnes with a irregular Ipo
25.31. Jumping logo
25.32. Particle system settings.
25.33. DupliVerted rectangles
25.34. Setting up mist.
25.35. Setting the mist parameters
25.36. Rendered particle rectangles.
25.37. Use the logo animation twice
25.38. The particles animation combined with the logo animation
25.39. Black-white transition.
25.40. White-video transition
25.41. Video-black transition
25.42. Combining the tunnel and the WireFrame cube
25.43. Combining the tunnel, WireFrame and solid cube.
25.44. Adding the particle/logo animation
25.45. Adding the logo zoom animation.
25.46. Adding one last detail
25.47. The complete sequence
26.1. Text Toolbar.
26.2. The GUI of our example.
26.3. The result of our example script.
28.1. Path selection in User Preferences menu.
28.2. The default options in Render Tab.
28.3. Yafray raytracer selection and its two sub-tabs.
28.4. Default Yafray tab with Yafray file export enabled (XML button).
28.5. Disabled Yafray export.
28.6. The rendering in progress for Yafray XML disabled.
28.7. The scene.
28.8. The scene as seen in the Viewport.
28.9. Rendered with Lamp at default settings.
28.10. The noise comes when sampling values is low.
28.11. The increase in sampling to 5 remove the noise.
28.12. The basic render from Area Light at default setting and value of 4.
28.13. Although the scene looks similar to Figure 28.11, “The increase in sampling to 5 remove the noise.” but is brighter and have better shadows.
28.14. The Spot lamp render with default settings.
28.15. Spot lamp with spherical light attenuation.
28.16. Spot lamp with Spherical attenuation enabled.
28.17. The Sun light at value 2. No wonder why this lamp is called Sun.
28.18. The Yafray GI tab.
28.19. The left part of image have the power of diffusion set at 2 while the right one at 4.
28.20. Using Full GI increases the time as well as realism.
28.21. The Yafray GI tab. Options for Full method are visible.
28.22. The Yafray tab.
28.23. Notice the noise on the wooden boards.
28.24. Increasing the sampling manually, and aperture size solves the problem.
28.25. HDRI render using Uffizi probe. It need more quality level.
29.1. Texture Dir setting and startup button.
29.2. Yable header Buttons.
29.3. Yable headerGeneral Setting Buttons.
29.4. Yable Global Illumination settings.
29.5. Background settings.
29.6. Fog Settings.
29.7. Depth of Field Settings.
29.8. Anti Noise Filter Settings.
29.9. Resolution Settings.
29.10. Rendering Settings.
29.11. Layer Selection.
29.12. Material Buttons.
29.13. Material Modulators.
29.14. Light GUI Panel.
29.15. Direct Light Options.
29.16. Caustics setup.
29.17. Caustics setup.
29.18. Car Paint.
29.19. Chrome parts.
29.20. Windshield and other glasses.

List of Tables

2.1. Minimum version external libraries
2.2. Platform dependent library requirements
2.3. Minimum version tools
29.1. Sample IORs

List of Examples

26.1. Script header
26.2. GUI drawing
26.3. Handling events
26.4. Script header